Wednesday, November 25, 2009

The Bi-N-Tic is on board, more or less

It's up and running, after some debugging. I expected some chaos, but not quite as much as I got...

When I first powered up the Bi-N-Tic, I got nothing out of it. Quick investigation showed that the VCO was not working. From reading a note on the Bridechamber page for this module, it turns out that there is a routing error on the board. Pin 1, the -15V supply pin, has no trace routed to it. Putting in a jumper to tie it to pin 4, which is also connected to -15V, solved that problem.

But when I fired it up and ran a signal through, it sounded terrible. There was major non-linearity and intermodulation happening inside the filter, with all kind of amplitude-modulation artifacts and distortion happening. Sending impulses through it revealed that there was a strong standing resonance at about 1200 Hz, which was impervious to any combination of control settings. It was this standing wave that appeared to be the source of the intermodulation. Plus, the frequency response of the filter section kept drifting around, and it didn't seem to have anything to do with the VCO.

If you look at the schematic of this filter, the audio section basically consists of four stages. Each stage consists of an opamp with some passive components on its inputs and in its feedback loop. The first stage buffers and combines the input with negative feedback from the second and third stages, which are the two actual filtering stages with the switching capacitors. The fourth stage buffers the output and filters out clock noise from the cap switching. To try to figure out what was going on with the filter, I tried eliminating all of the feedback paths. Turning the resonance path all the way down eliminates feedback from the second stage; unsoldering a 100K resistor eliminated feedback from the third stage.

In this configuration, I noted two things: the third stage output floated to a very high DC level, and it produced weird buzzing and clicking noises. And the output level varied as I touched things. By putting a 100K resistor between the output and the inverting input of the IC, I stabilized the stage and got rid of the DC offset. This led me to discover two bad solder joints. One was on one of the switching caps in the third stage, which accounted for the buzzing and clicking. The other wasn't in the module itself -- it was at a power supply return connection.

Now that I've fixed these things and re-soldered the resistor I removed, it's apparently behaving. I say "apparently" because I'm not really certain how it's intended to behave. I'm not sure what I expected when I ordered this module, but whatever it was, this wasn't quite it. The module's behavior is best described, I think, as a bandpass filter that has a comb-shaped response within the passband. It's highly resonant and close to self-oscillation most of the time. It's also possible to make the bandwidth very narrow -- so narrow that it can pick out individual partials from a square wave!

The final step was to make some panel graphics mods to correspond to the changes I made to the module (intentionally and inadvertently). I've done this before; I type/draw bits of graphics in OmniGraffle, print them on an inkjet printer, cut them with scissors to the needed shape, and then tape them onto the panel with transparent tape. Only this time, the "transparent" tape wasn't so much...



I'm not sure what happened with that. I used this same tape before on an MOTM panel, and it worked fine. Something is subtly different about the finish on this Bridechamber panel such that the tape doesn't make full contact with the surface. It sticks, but it's not all the way down, so to speak. Maybe at some point I'll try it again with different tape, but right now I don't feel like fooling it.

Here's another view, with different lighting:


And a close-up of the modified graphics:


Finally for some audio samples. First, some basic filtering of a square wave:


Second, using the self-excite, with various selections of the excite waveform rotary switch, and the cap bank split/combine switch, in addition to playing with the resonance and bandwidth:


Finally, a freak-out using excite and external sync from an LFO, in addition to square and pulse wave input. Note a few spots near the end where the filter is pushed up into the supersonic and produces some really strange artifacts:


There's still some work to be done; the calibration of the FM inputs is way off (about one semitone per volt on the V/octave input). But I'm moving on to other projects right now.


2 comments:

Jeroen said...

Hey

I'm also building the Bi-N-Tic at the moment , and mine sounds quite like yours. pretty distorted and unpredictable..
What parts did u use for the FET and other interchangeable key parts? Could you post some pics of your soldered PCB? maybe we could help each other out here because there doesnt seem to be a lot of info on the web about this particular module..

cheers,
Jeroen

Jeroen said...

aah, sorry.
i just discovered there some more info on your bi-n-tic build.
i'll read that first :)